Delays in syncing events from Hustle to Blackbaud Luminate
Incident Report for Hustle
Resolved
This incident has been resolved. Syncing back of Blackbaud Luminate events should be up to date.
Posted May 06, 2020 - 21:22 UTC
Update
Fix forthcoming soon.
Posted May 06, 2020 - 17:47 UTC
Investigating
We have identified the issue and are currently working on a fix.
Posted May 06, 2020 - 17:46 UTC