Login Provider is Down
Incident Report for Hustle
Resolved
This incident has been resolved.
Posted Oct 30, 2023 - 20:26 UTC
Update
We are continuing to investigate this issue.
Posted Oct 30, 2023 - 20:26 UTC
Investigating
Our login provider is experiencing issues. We are monitoring for their resolution.
Posted Oct 30, 2023 - 20:23 UTC
This incident affected: Admin Panel (admin.hustle.com), Agent App (web.hustle.com), and Backend Infrastructure.