Admin panel not loading

Incident Report for Hustle

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 22:15 UTC

Monitoring

The issue was identified and a change deployed. The team is monitoring the change.
Posted Apr 17, 2025 - 21:26 UTC

Investigating

We are currently investigating reports that the admin panel is not loading or slowly loading for some admins.
Posted Apr 17, 2025 - 21:02 UTC
This incident affected: Admin Panel (admin.hustle.com).