Canadian Lead Creation Currently Unavailable
Incident Report for Hustle
Resolved
Thank you for your continued patience— all components are fully functional for all Canadian organizations. If you are still experiencing issues with creating leads, please reach out to support@hustle.com
Posted May 18, 2018 - 07:00 UTC
Monitoring
At this time we have a temporary work-around for uploading contacts within Canadian groups. Please contact support@hustle.com if you're running into this issue so that we may assist. Thank you for you patience as we work with our telephone number vendor towards a speedy resolution!
Posted May 16, 2018 - 00:46 UTC
Identified
We're currently working with our telephone number vendor to address a Lead creation issue with Canadian clients. If you are experiencing an issue with uploaded contacts not showing up, please reach out to support@hustle.com.
Posted May 15, 2018 - 19:31 UTC
This incident affected: Admin Panel (admin.hustle.com).