Performance degradation
Incident Report for Hustle
Resolved
The incident has been resolved and all Hustle components are operating normally. If you have any ongoing issues, please contact us at support@hustle.com.
Posted Oct 27, 2018 - 01:34 UTC
Monitoring
Our system is recovering from the earlier degradation. All aspects are once again usable. We will continue to monitor our systems to ensure a complete recovery.
Posted Oct 27, 2018 - 00:02 UTC
Investigating
We are actively investigating a widespread performance degradation of the Hustle service across both mobile and web. Thank you for your patience, and we’ll update you soon.
Posted Oct 26, 2018 - 23:32 UTC
This incident affected: Admin Panel (admin.hustle.com), Agent App (web.hustle.com), and Backend Infrastructure.