Degraded performance issues causing severe delays
Incident Report for Hustle
Resolved
The earlier issues have been resolved, and all systems are performing normally. We will be monitoring this heavily throughout the morning tomorrow.
Posted Jun 05, 2018 - 05:35 UTC
Identified
We have identified an issue where some clients are and are experiencing loading issues or blank screen. We are currently working towards a resolution and expect to have an update shortly. If you are experiencing this, there is no need to contact us.
Posted Jun 05, 2018 - 04:34 UTC
This incident affected: Admin Panel (admin.hustle.com), Agent App (web.hustle.com), and Backend Infrastructure.